Ran into my first blog hosting bug… that was fast…

Within a few hours of being up, I ran into this issue... odd, since it doesn’t appear to be affecting very many folks…

.Text Threading Bug
...If you are one of the 7 regular readers here you might have noticed some problems over the last few weeks. Every so often .Text would display an error page with the message: “Value cannot be null. Parameter name: value”. Once the error happened it would stick around until the application restarted. Unfortunately, the error was appearing everyday. After asking around on some of the boards to no avail I did some sleuthing…

Author: Duncan Mackenzie

I'm the Developer Lead for the Channel 9 team, formerly worked on MSDN as a developer, content strategist and author.

2 thoughts on “Ran into my first blog hosting bug… that was fast…”

  1. When I found this bug I wondered how in the world it was happening to my site, which gets 3 or 4 orders of magnitude less traffic then blogs.msdn.com.

    Then it finally hit me.

    On the main page of the site I pull the RSS feed of my “.net news” blog and display the items in a table. The RSS feed includes the aggbug image link to track aggregator hits. When http://asp.net would link to an article on OdeToCode, quite a number of people rush in and hit the main page, and each page hit triggers 5 aggbug entries. This is where the bug lived – in counting up the aggregator hits from the aggbug image. I have since stripped the aggbug image tag from the feed before displaying it on the main page and can now enable queued stats again.

  2. Hi i was wondering if you could help me.. I am setting up a Vb 6.0 front end to a MS Access Database – I know its something to do with odbc and ole’s but my time frame is limited and i need to connect it asap so i can get on with manipulating the database from the front end. I dont suppose any of you know off hand how to do this?

Leave a Reply

Your email address will not be published. Required fields are marked *